#EvdeKAL

Sans-serif

Aa

Serif

Aa

Font büyüklüğü

+ -

Satır yüksekliği

+ -
Gündüz
Gece
Gün Batımı

WordPress Güvenli Olmayan PHP Sürümü Hatası ve Çözümü

Bu yazımda “WordPress, sitenizin güvenli olmayan bir PHP sürümü üzerinde çalıştığını tespit etti” hatasını inceleyeceğiz ve çözümünü anlatacağım. Php güncellemeleri konusunda hosting firmanız ile görüşmeniz ve güncelleme yetkisine sahip olmanız gerektiğini belirtmeliyim. Hosting firmaları panel sürümlerini güncel tutmazlar. Bundan dolayıda bu sorunlar karşımıza çıkar.

Genelde wordpress versiyonu ve eklenti güncellemelerimizde karşımıza çıkan bir sorundur. Özellikle son gelen WordPress 5.4.1 güncellemesi sonrasında kullanıcıların sık karşılaştığı bir hata olan php sürüm hatasının çözümünü anlatacağım.

Güncel Php Sürümü Ne Olmalı?

Şu anda güncel php sürümü 7.3 versiyonudur. Hosting firmalarının çoğu 5.3 ya da 5.4 sürümünü kullanır. Buda biz kullanıcıların karşısına bu tür versiyon güncelleme sorunlarını çıkarır.

Bu sürümler geliştirme sürelerini doldurmuş destek alınamayacak sürümlerdir. EOL (End of life) denilen sürümlerdir. WordPress php altyapısı ile çalıştığı için aslında bu altyapıların ağır yükünü php taşımaktadır. WordPress kullanabilmek için minimum 5.2 php sürümüne sahip olmanız gerekmektedir. Ancak eski sürüm destekliyor diye php sürümünüzüde güncellememek ilerleyen süreçte ciddi sorunlara, yavaşlamalara ve gelişen eklentileri kullanamamanıza neden olmaktadır. Bu açıdan CMS altyapılarında gelişen güncellemeleri takip ederek php sürümünüzü güncellemenizde fayda var.

Php Sürümü Güncellememenin Dezavantajları

  • Yavaş site açılışları
  • Site açıkları
  • Daha az sunucu yükü
  • Modern teknolojileri ve gelişmeleri desteklememesi

Php Sürümü Güncellemenin Avantajları

  • Site açılış hızınız artar
  • Kapatılan güvenlik açıkları. (Son gelen 5.4.1 sürüm güncellemesi 11 açık kapatılmıştır. Detaylı bilgi için tıklayınız.
  • Modern web uygulamaları ve teknolojileri ile tam uyumluluk.
  • Güncel php özelliklerine erişim.
  • Eski sürümlerden %400 daha hızlıdır.

Php Sürümü Hatası

Karşılaştığımız Php Sürümü Hatası

Php Sürümü Hatası Çözümü

Çalıştığım hosting firmam cPanel yönetim paneline sahip olduğu için cPanel üzerinden php sürüm güncellemesini anlatmaya çalışacağım.

cPanel > Yazılım başlığı altında yer alan “Select PHP Version” alanını bulmanız gerekiyor.

cPanel Php Sürümü Güncelleme

Select PHP Version kısmına tıkladıktan sonra karşımıza çıkan ekranda PHP version bölümünde hosting firmanızın desteklediği php sürümlerinin listesini göreceksiniz. Versiyonları incelediğimizde 7.0, 7.1, 7.2, 7.3 sürümlerini göreceğiz. Burada dikkat etmemiz gereken detay 7 ve üstü bir versiyon seçmemiz gerekiyor. Versiyonu seçtikten sonra “Set as current” kısmına tıklayacaksınız.

Güncel Php Sürümünü Seçerek Set as current kısmına tıklayarak kaydediyoruz.

Belirttiğim adımları uygulayarak kaydettiyseniz artık sizde güncel Php sürümüne sahipsiniz demektir. WordPress panelinizi ziyaret ettiğinizde karşınıza çıkan WordPress, sitenizin güvenli olmayan bir PHP sürümü üzerinde çalıştığını tespit etti hatasının ortadan kalktığını göreceksiniz.

Ek olarak cPanel tarafından hazırlanan Php versiyon güncellemesinin video anlatımıda paylaşıyorum.

Php Versiyon Güncellemesi Video Anlatım

Php Güncelleme İşlemi Sonrası Değerlendirme

Ben Php sürümümü 7.3 sürümüne güncelledim. Php sürümü güncellemeleri sitenizin açılış hızına ve yönetim panelinizin kullanımına kadar size birçok avantaj sağlar.

Php 7.3 sürümü ve yazı ile ilgili düşüncelerinizi yorum bölümünde benimle paylaşırsanız sevinirim.

Bir cevap yazın


This site uses Akismet to reduce spam. Learn how your comment data is processed.